MyKinsta service disruption
Incident Report for Kinsta
Resolved
Our engineers have resolved the issue. All services are fully operational again.
Posted Mar 04, 2020 - 12:42 UTC
Investigating
Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted Mar 04, 2020 - 11:10 UTC
This incident affected: MyKinsta.