MyKinsta service disruption
Incident Report for Kinsta
Resolved
This incident has been resolved.
Posted Oct 01, 2019 - 23:47 UTC
Monitoring
Service to MyKinsta has been restored. We are continuing to monitor and investigate the situation until it is resolved.
Posted Oct 01, 2019 - 23:09 UTC
Investigating
Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted Oct 01, 2019 - 22:37 UTC
This incident affected: MyKinsta.