MyKinsta service disruption
Incident Report for Kinsta
Resolved
Our Engineers have successfully restored full service to our control panel, MyKinsta. If you are still unable to log into MyKinsta please contact our support team by sending an email to support@kinsta.com. We do apologize for this disruption to your business.
Posted Mar 04, 2020 - 14:53 UTC
Monitoring
Our engineers have restored service to MyKinsta at this time. We are continuing to monitor its performance. Please feel free to reach out to us as support@kinsta.com if you are experiencing any issues using MyKinsta and cannot access our live chat.
Posted Mar 04, 2020 - 14:15 UTC
Update
If you're a Kinsta customer and have an urgent support need while MyKinsta is down please send an email to support@kinsta.com and our engineers will continue to assist you as they can over email.
Posted Mar 04, 2020 - 14:09 UTC
Investigating
Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.

Updates will be provided by our status page, we apologize for the inconvenience.
Posted Mar 04, 2020 - 14:03 UTC
This incident affected: MyKinsta.