Kinsta CDN service disruption
Incident Report for Kinsta
Resolved
This incident has been resolved.
Posted May 30, 2020 - 20:23 UTC
Investigating
Our Engineers are investigating reports of performance issues with our CDN, Kinsta CDN. We are working on restoring normal service to the Kinsta CDN as quickly as possible.
Posted May 30, 2020 - 13:28 UTC
This incident affected: Kinsta CDN.