MyKinsta service disruption
Incident Report for Kinsta
Resolved
Our Engineers have successfully restored full service to our control panel, MyKinsta. If you are still unable to log into MyKinsta please contact our support team by sending an email to support@kinsta.com. We do apologize for this disruption to your business.
Posted Mar 17, 2022 - 15:23 UTC
Monitoring
Our Engineers have implemented a fix and are monitoring the results.
Posted Mar 17, 2022 - 15:16 UTC
Investigating
Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible. If you need to reach out to our Support Team, please email support@kinsta.com.
Posted Mar 17, 2022 - 15:09 UTC
This incident affected: MyKinsta.