MyKinsta service disruption
Incident Report for Kinsta
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 18, 2019 - 21:20 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 4 months ago. Mar 18, 2019 - 21:16 UTC
Investigating
Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted 4 months ago. Mar 18, 2019 - 20:59 UTC
This incident affected: MyKinsta.