Connectivity issues with some US ISPs
Incident Report for Kinsta
Resolved
All of our tests indicate this situation is resolved; however, if you believe you're still experiencing issues, please contact our team.
Posted 8 months ago. Nov 12, 2018 - 23:25 UTC
Identified
We're aware there may be issues connecting to Kinsta from some US ISPs. These may show as connection timeouts when connecting to Kinsta or Kinsta-hosted websites.

These issues appear to be outside of our control, but we'll continue investigating.
Posted 8 months ago. Nov 12, 2018 - 22:26 UTC
This incident affected: MyKinsta, Kinsta.com, Iowa (US Central) data center, Los Angeles (US West 2) data center, Northern Virginia (US East 4) data center, Oregon (US West) data center, and South Carolina (US East 1) data center.