MyKinsta service disruption
Incident Report for Kinsta
Resolved
This matter has now been resolved!
Posted May 18, 2020 - 14:26 UTC
Monitoring
A fix has been implemented and we are monitoring the situation to ensure MyKinsta remains stable.
Posted May 18, 2020 - 14:04 UTC
Identified
The issue has been identified and a fix is currently being implemented!
Posted May 18, 2020 - 13:52 UTC
Investigating
Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted May 18, 2020 - 13:49 UTC
This incident affected: MyKinsta.