Email Deliverability Performance
Incident Report for Kinsta
Resolved
We are happy to inform that our outbound email system has been delisted from the spam-list provider.
Posted Jun 23, 2020 - 17:14 UTC
Investigating
We are currently aware of email sending issues affecting customers who are not using their own SMTP services on our platform. Email deliverability may be affected due to one of our IP addresses being blacklisted by a reputable spam-listing provider.

Our team is diligently working to de-list our IP address. If you are having issues sending emails from a site hosted on Kinsta, we advise you to set up a third-party sending service through many of the available providers such as sendgrid, mailgun, etc.

https://kinsta.com/knowledgebase/sendgrid-wordpress/
Posted Jun 22, 2020 - 21:38 UTC
This incident affected: Outbound Email System.