Disruption with Cloudflare's Proxy Service
Incident Report for Kinsta
Resolved
This incident has now been resolved.
Posted May 07, 2021 - 01:15 UTC
Monitoring
We have received an update from Cloudflare confirm the update/change that was causing this issue has now been rolled back and are no longer seeing any errors in relation to this issue.

We will continue to monitor the situation.
Posted May 07, 2021 - 00:40 UTC
Update
We have received communication from Cloudflare that the change/update which has caused this disruption is being rolled back. We do not have an expected duration for how long the rollback may take but will provide another update here once we've received more information.

For now, we suggest keeping the Cloudflare proxy disabled.

Thank you for your continued patience while we work with Cloudflare to resolve this matter.
Posted May 06, 2021 - 20:20 UTC
Update
We've received an update from Cloudflare that are working on a fix to the root cause, we will provide another update once we receive additional details from Cloudflare.

While Cloudflare is working on this problem we recommend disabling the Cloudflare proxy. This can be done by logging into your Cloudflare account, navigating to the DNS section, and clicking on the orange cloud icon. Once it displays as a grey cloud your site availability will be restored.
Posted May 06, 2021 - 18:58 UTC
Update
The situation regarding 522 Cloudflare proxy errors continue. While Cloudflare is working on this problem we recommend disabling the Cloudflare proxy. This can be done by logging into your Cloudflare account, navigating to the DNS section, and clicking on the orange cloud icon. Once it displays as a grey cloud your site availability will be restored.

We apologize for the continued difficulties and will provide additional updates as they become available.
Posted May 06, 2021 - 16:13 UTC
Update
The situation regarding 522 Cloudflare proxy errors continue. While Cloudflare is working on this problem we recommend pausing the Cloudflare proxy to restore service.

You can find instructions on this here: https://support.cloudflare.com/hc/en-us/articles/203118044-How-do-I-temporarily-pause-Cloudflare-#h_8654c523-e31e-4f40-a3c7-0674336a2753
Posted May 06, 2021 - 13:45 UTC
Identified
Customers who are using their own Cloudflare proxy service are experiencing disruptions.

While Cloudflare is working on this problem we recommend pausing the Cloudflare proxy to resolve the problem. You can find instructions on this here: https://support.cloudflare.com/hc/en-us/articles/203118044-How-do-I-temporarily-pause-Cloudflare-#h_8654c523-e31e-4f40-a3c7-0674336a2753

This issue is not affecting customers using Kinsta's Cloudflare integration.
Posted May 06, 2021 - 12:08 UTC
This incident affected: Cloudflare Integration.