MyKinsta service disruption
Incident Report for Kinsta
Resolved
Our engineers have applied a fix and are no longer seeing issues with Authy two-factor authentication in MyKinsta.

If you are experiencing issues, please try to fully refresh your browser (Cmd+R) or contact our support team for more assistance.
Posted Oct 12, 2020 - 18:00 UTC
Identified
Our development team has identified an issue affecting Authy two-factor users and is currently working to implement a fix.
Posted Oct 12, 2020 - 17:05 UTC
Investigating
Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.

Currently, this is only affecting users who have enabled two-factor authentication.
Posted Oct 12, 2020 - 16:43 UTC
This incident affected: MyKinsta.