Revoked Let's Encrypt Certificates
Incident Report for Kinsta
Resolved
We have received notification from Let's Encrypt that they will be revoking some, but not other certificates, decreasing the likelihood of affected sites. Our engineers used the time while Let's Encrypt was hesitating to identify all sites on our network that could be affected and to update certificates manually to make sure whatever happens, our clients are protected. This process will be completed very shortly.

We are considering this issue resolved. If you have any issues at all with your Let's Encrypt certificate please don't hesitate to reach out to support.
Posted Mar 05, 2020 - 07:28 UTC
Monitoring
As of this time Let's Encrypt has not started revoking certificates. Our team is continuously working to minimize the effect of eventual revocations. Our latest information from Let's Encrypt is that the procedure will be started around 8pm UTC today (4th of March). We will monitor the situation and provide updates here.
Posted Mar 04, 2020 - 10:28 UTC
Identified
We have received news from Let’s Encrypt that due to a security issue they will be revoking a significant number of certificates. You can read the announcement here: https://community.letsencrypt.org/t/revoking-certain-certificates-on-march-4/114864

As soon as our team received this information, we have been working to replace as many certificates as we possibly can prior to them being revoked. Some certificate regenerations are failing due to domain expirations or DNS no longer pointing to Kinsta.

Our engineers can and will go through each alerting site one-by-one and will fix these issues manually but that will take a significant amount of time. If you experience issues with your site's Let's Encrypt SSL certificate being revoked, please let our support team know. We have set up internal procedures to give priority to these issues and we will work towards solving each issue as fast as humanly possible.
Posted Mar 03, 2020 - 21:23 UTC
This incident affected: Belgium (BE) data center, Eemshaven (NL) data center, Finland (FI) data center, Frankfurt (DE) data center, Hong Kong (HK) data center, Iowa (US Central) data center, London (UK) data center, Los Angeles (US West 2) data center, Montreal (CA) data center, Mumbai (IN) data center, Northern Virginia (US East 4) data center, Oregon (US West) data center, Osaka (JP) data center, São Paulo (BR) data center, Singapore (SG) data center, South Carolina (US East 1) data center, Sydney (AU) data center, Taiwan (TW) data center, Tokyo (JP) data center, and Zürich (CH) data center.