Outgoing Email Disruption
Incident Report for Kinsta
Resolved
We're happy to report that SendGrid has marked this issue as officially resolved. Delayed mail has been dequeued and all impacted services are up and running again.
Posted Jul 28, 2020 - 22:11 UTC
Monitoring
SendGrid has resolved the issue, and are currently monitoring the situation. We will post a final update once the issue is marked fully resolved. Thank you once more for your patience!
Posted Jul 28, 2020 - 19:43 UTC
Identified
SendGrid has identified the issue affecting some of their infrastructure, and are working to fully resolve it. We are seeing that sending and receiving emails is working as expected. We'll provide an update once SendGrid has confirmed the issue is fully resolved.
Posted Jul 28, 2020 - 19:11 UTC
Update
SendGrid are continuing to investigate the issue. Although there may be delays in emails being delivered, they will still arrive. We will provide further updates as they become available. Thank you for your continued patience!
Posted Jul 28, 2020 - 16:51 UTC
Update
Our email service partner, SendGrid, is continuing to investigate this issue. Thank you for your continued patience! We will provide further updates as they become available. Our apologies for any disruptions this may cause!
Posted Jul 28, 2020 - 15:03 UTC
Update
Our email service partner, SendGrid, is continuing to investigate this issue. We will provide further updates as they become available.
Posted Jul 28, 2020 - 13:45 UTC
Investigating
Our email service partner, SendGrid, is currently experiencing a service disruption. This can affect Kinsta customers sending emails from their sites, as well as emails sent from MyKinsta. We apologise for the issues and will update you as soon as new information is available.

Sendgrid is reporting this incident on their Status page here:
https://status.sendgrid.com/incidents/c2k6nqpr9t7p
Posted Jul 28, 2020 - 13:12 UTC
This incident affected: Outbound Email System.