MyKinsta service disruption
Incident Report for Kinsta
Resolved
Our Engineers have successfully restored full service to our control panel, MyKinsta. If you are still unable to log into MyKinsta please contact our support team by sending an email to support@kinsta.com. We do apologize for this disruption to your business.
Posted Jul 10, 2019 - 17:11 UTC
Investigating
Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible. The incident appears to be originating from an outage with our payment processor, stripe. Please see: https://status.stripe.com/ for more details.
Posted Jul 10, 2019 - 16:51 UTC
This incident affected: MyKinsta.