MyKinsta is experiencing degraded performance
Incident Report for Kinsta
Resolved
Our Engineers have successfully restored full service to our control panel, MyKinsta. If you have any further issues, please contact our support team for assistance.
Posted Oct 25, 2022 - 20:35 UTC
Monitoring
Our Engineers have successfully restored full service to our control panel, MyKinsta. If you are still unable to log into MyKinsta please contact our support team by sending an email to support@kinsta.com. We do apologize for this disruption to your business, and we are continuing to monitor for further impact.
Posted Oct 25, 2022 - 18:35 UTC
Investigating
Our Engineers are investigating further reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible. If you cannot access MyKinsta for support during this time, please send an email to support@kinsta.com.
Posted Oct 25, 2022 - 15:30 UTC
Monitoring
MyKinsta's performance continues to be stable, our team is actively monitoring and investigating further.
Posted Oct 25, 2022 - 09:05 UTC
Update
MyKinsta's performance is now stable, but we continue investigating to identify the root cause. We'll continue to provide updates as they come.
Posted Oct 25, 2022 - 05:14 UTC
Update
We are continuing to investigate this issue. We apologize for the inconvenience.
Posted Oct 25, 2022 - 04:41 UTC
Update
We are continuing to investigate this issue as we're seeing a delay across multiple requests resulting in some timing out in MyKinsta. The issue mainly affects the Invoices page but could affect other MyKinsta pages too. We apologize for the inconvenience. We'll give another update as soon as it is available.
Posted Oct 25, 2022 - 03:01 UTC
Update
We are continuing to investigate this issue. We apologize for the inconvenience.
Posted Oct 25, 2022 - 01:54 UTC
Investigating
We are currently investigating this issue.
Posted Oct 25, 2022 - 00:56 UTC
This incident affected: MyKinsta.