MyKinsta service disruption

Incident Report for Kinsta

Resolved

MyKinsta is continuing to perform normally and the service is stable. If you are still unable to log into MyKinsta, or are experiencing any performance issues with the service please contact our support team via live chat or by sending an email to support@kinsta.com. We do apologize for this disruption to your business.
Posted Jun 12, 2025 - 21:54 UTC

Monitoring

MyKinsta is accessible and performing normally again. We will continue to monitor the service to ensure it's ongoing stability. If you are continuing to experience any issues however please do not hesitate to reach out to our Support team. We apologize about the disruption to your business.
Posted Jun 12, 2025 - 19:00 UTC

Investigating

Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted Jun 12, 2025 - 18:24 UTC
This incident affected: MyKinsta.