Service disruption at the Iowa (US Central) data center

Incident Report for Kinsta

Resolved

This has been resolved.
Posted Feb 24, 2025 - 21:28 UTC

Monitoring

This has been resolved now; please contact us if you are experiencing any other issues.
Posted Feb 24, 2025 - 20:25 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 24, 2025 - 20:24 UTC

Investigating

Our Engineers are investigating reports of a service disruption affecting sites in the Iowa (US Central) data center. We are working to restore service to affected sites as quickly as possible.
Posted Feb 24, 2025 - 19:59 UTC
This incident affected: Iowa (US) data center.