Service disruption at the Iowa (US Central) data center
Incident Report for Kinsta
Resolved
Our Engineers have successfully restored full service to all affected sites in the Iowa (US Central) data center. If you are still seeing issues with your website please contact our support team. Thank you for your patience and we do apologize for any disruption to your business.
Posted Dec 31, 2020 - 05:34 UTC
Monitoring
Our Engineering team has resolved the service issues and affected sites are back online. We will continue to monitor the situation as we take additional steps to ensure the integrity of the file system which may result in momentary downtime for sites that were affected by this issue.
Posted Dec 31, 2020 - 00:04 UTC
Identified
Our Engineering team continues their efforts towards restoration of service to the affected machine. We will continue with further updates as more information becomes available.
Posted Dec 30, 2020 - 22:38 UTC
Investigating
We are seeing increased errors on the affected host machine at this time and sites may be experiencing connection issues. Our Engineering team is investigating now.
Posted Dec 30, 2020 - 21:25 UTC
Monitoring
Our Engineering team has completed the file system restoration process and affected sites are now back online. We will continue to monitor the situation as we take additional steps to ensure the integrity of the file system which may result in very brief downtime for any sites that were affected by this issue.

If you were affected by this incident we will be reaching out to you directly with more information very soon.
Posted Dec 30, 2020 - 20:00 UTC
Update
We have isolated the cause of this outage to a corrupted file system. Our Engineering team has exhausted all available options to repair the corrupted file system and at this time we are restoring the file system from our most recent unaffected backup.

A status update on the restore process will be provided within the hour on our status page here and additional steps are taking place to contact those customers directly affected as soon as possible.
Posted Dec 30, 2020 - 19:04 UTC
Update
At this time we do not have any additional details to share as our Engineering team continues their efforts towards restoration of service to the affected host machine. We will continue with further updates within the hour as more information becomes available.
Posted Dec 30, 2020 - 18:17 UTC
Update
Our Engineering team continues their efforts towards restoration of service to the affected host machine.
Posted Dec 30, 2020 - 17:04 UTC
Update
Our Engineering team continues to work towards restoration of service to the affected host machine.
Posted Dec 30, 2020 - 16:08 UTC
Update
Our Engineering team has identified the underlying issue and is working to identify the best route towards resolution, we will provide another update within the hour as more information becomes available.
Posted Dec 30, 2020 - 15:06 UTC
Update
Our Engineers are currently working to implement a fix related to the container management and disk I/O activity for a single host machine within our Iowa location. Sites located on the affected host machine will not be accessible during this time, however we will provide another update within the next hour. We appreciate your continued patience and understanding!
Posted Dec 30, 2020 - 14:11 UTC
Update
We are continuing to work on a fix for this issue.
Posted Dec 30, 2020 - 13:30 UTC
Identified
We are working to restore services as quickly as possible, we appreciate your continued patience.
Posted Dec 30, 2020 - 12:57 UTC
Investigating
Our Engineers are investigating reports of a service disruption affecting sites in the Iowa (US Central) data center. We are working to restore service to affected sites as quickly as possible.
Posted Dec 30, 2020 - 11:27 UTC
This incident affected: Iowa (US) data center.