MyKinsta Dashboard Outage | Websites affected too

Incident Report for Kinsta

Resolved

We have been monitoring the situation and have observed that all services continue to remain fully active. As such, we will be marking this incident as resolved. If you experience any further issues, please do not hesitate to contact our Support team through MyKinsta or by emailing support@kinsta.com. We appreciate your patience and understanding throughout this extended and impactful incident.
Posted Nov 18, 2025 - 18:42 UTC

Update

Cloudflare has updated its status page to confirm that the issue has been resolved, with full service continuing to remain active. We will continue to monitor the situation from our end for a short period before updating our status page to resolved. We apologise again for the disruption to service and the impact this has caused, and thank you for your patience while we worked through this.
Posted Nov 18, 2025 - 18:07 UTC

Update

We are continuing to monitor the situation while Cloudflare focus on ensuring that full service remains active. Thank you for your continued patience.
Posted Nov 18, 2025 - 17:13 UTC

Update

We are continuing to monitor the situation.
Posted Nov 18, 2025 - 16:16 UTC

Monitoring

We are observing that both sites on our platform and MyKinsta are remaining online. We will continue to closely monitor the situation and provide further updates as they become available, as Cloudflare is still focusing efforts on keeping services active after applying the fix.
Posted Nov 18, 2025 - 15:50 UTC

Update

We are continuing to closely monitor the situation and will provide updates as they become available.
Posted Nov 18, 2025 - 15:34 UTC

Update

Cloudflare has updated its status page to confirm that they have implemented a fix and believes the incident is now resolved. While we are seeing that sites on our platform are now responding as expected, we will continue to closely monitor the situation and provide updates as they become available. Thank you for your continued patience throughout this incident.
Posted Nov 18, 2025 - 14:49 UTC

Update

Cloudflare continues to work on restoring the services:

https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 14:11 UTC

Update

We are still seeing issues with a number of sites. Cloudflare continues to work on this:

https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 13:39 UTC

Identified

Our 3rd party provider Cloudflare has identified the issue and is applying the fix: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 13:18 UTC

Update

Our 3rd party provider Cloudflare is still investigating the issue: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 13:01 UTC

Update

The services are recovering, but errors still occur on occasion. Cloudflare continues to work on this:

https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 12:32 UTC

Update

Our 3rd party provider Cloudflare reported global network outage issues, they are investigating:
https://www.cloudflarestatus.com/incidents/8gmgl950y3h7

We will provide updates here as soon as they become available.
Posted Nov 18, 2025 - 11:53 UTC

Investigating

We are currently investigating issues with our MyKinsta dashboard loading.
Certain websites may be affected by this issue and show 500 error.

It seems that the issue is with our 3rd party service provide Cloudflare:
https://www.cloudflarestatus.com/incidents/swzl0f0hxy68

We are following for updates and will update as soon as possible.
Posted Nov 18, 2025 - 11:45 UTC
This incident affected: MyKinsta and Cloudflare Integration.