MyKinsta actions failing

Incident Report for Kinsta

Resolved

All MyKinsta services that rely on Cloudflare's API are stable at this time. This issue has now been resolved. If you are still experiencing any issues however please contact our support team by sending an email to support@kinsta.com or by opening a live conversation within MyKinsta.
Posted Sep 12, 2025 - 20:03 UTC

Monitoring

We are seeing actions completing successfully again in MyKinsta at this time. We are monitoring to ensure the continued stability of the Cloudflare API requests. If you are still experiencing any issues however please contact our support team by sending an email to support@kinsta.com or by opening a live conversation within MyKinsta. We do apologize for this disruption to your business.
Posted Sep 12, 2025 - 19:27 UTC

Identified

Our Engineers are aware of reports of certain actions failing with our control panel, MyKinsta. This includes actions such as adding new domains. This appears to be related to a Cloudflare API issue that is currently ongoing. Cloudflare's own status page can be found at https://www.cloudflarestatus.com/incidents/psxnp8bzv81b. We are working on restoring normal service to MyKinsta as quickly as possible.

If you do have any questions please do not hesitate to reach out to our Support team for assistance.
Posted Sep 12, 2025 - 18:41 UTC
This incident affected: MyKinsta.