MyKinsta's Company Analytics page is currently unavailable.

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 11:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2026 - 11:02 UTC

Update

Our developers are still investigating the issue. We will provide updates as we make progress.
Posted Jan 14, 2026 - 10:15 UTC

Investigating

The MyKinsta Company Analytics page is currently unavailable and redirects to the Dashboard homepage. We are investigating this issue and apologize for the inconvenience.
Posted Jan 14, 2026 - 04:25 UTC
This incident affected: MyKinsta.