MyKinsta Support System Unavailable
Incident Report for Kinsta
Resolved
Our support system is now available. We do apologize for any difficulties you experienced attempting to reach our support team.
Posted 2 months ago. Aug 13, 2019 - 16:33 UTC
Investigating
Our support system is not currently available. We are working to resolve the issue as quickly as possible.
Posted 2 months ago. Aug 13, 2019 - 16:32 UTC
This incident affected: Kinsta support system.