MyKinsta - Slower performance.

Incident Report for Kinsta

Resolved

Our Engineers have successfully restored full service to our control panel, MyKinsta. If you are still unable to log into MyKinsta please contact our support team by sending an email to support@kinsta.com. We do apologize for this disruption to your business.
Posted Mar 13, 2025 - 17:00 UTC

Update

Our Engineers are continuing to monitor for any further issues.
Posted Mar 13, 2025 - 15:25 UTC

Monitoring

There were reports with high loads on our MyKinsta database causing slower performance or stuck operations.
A temporary fix is already in place and we are currently working on a long term solution.
Posted Mar 13, 2025 - 14:32 UTC
This incident affected: MyKinsta.