MailChannels delivery delays
Incident Report for Kinsta
Resolved
Posted Oct 09, 2024 - 22:25 UTC
Identified
Our mail relay provider, MailChannels, has reported delays with deliveries in some cases. This may impact delivery of some transactional email. We are monitoring their status currently: https://status.mailchannels.net/incidents/ycg80nx661jw
Posted Oct 09, 2024 - 22:00 UTC