Email deliverability issue with Kinsta's transactional email service (MailChannels)
Incident Report for Kinsta
Resolved
Posted Oct 08, 2024 - 00:59 UTC
Identified
Our partner email service provider for transactional emails (MailChannels) is experiencing email deliverability issues with Microsoft destinations such as hotmail.com, outlook.com, msn.com, and live.com. https://status.mailchannels.net/incidents/4qz7d765rqzn. We are actively monitoring this problem and will provide updates as soon as they become available.
Posted Oct 08, 2024 - 00:29 UTC
This incident affected: Outbound Email System.