New account creation error on MyKinsta
Incident Report for Kinsta
Resolved
This incident has now been resolved.
Posted Jun 10, 2023 - 11:53 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2023 - 10:39 UTC
Identified
The issue has been identified and is currently receiving emergency attention from the engineering team.
Posted Jun 10, 2023 - 10:13 UTC
Investigating
We are currently investigating an issue where new account signups are failing due to an error in the country selection dialogue.
Posted Jun 10, 2023 - 09:57 UTC
This incident affected: MyKinsta.