MyKinsta's Downloadable and External backups are currently undergoing maintenance.

Incident Report for Kinsta

Resolved

This maintenance has been completed successfully.
Posted Jan 27, 2026 - 05:32 UTC

Update

This maintenance is still ongoing. Updates will be posted as soon as they become available.
Posted Jan 27, 2026 - 04:49 UTC

Monitoring

The Downloadable and External Backup features in MyKinsta will be unavailable due a planned maintenance. We hope to complete this maintenance within 30 minutes. We apologize for the inconvenience.
Posted Jan 27, 2026 - 04:17 UTC
This incident affected: MyKinsta.