Application & Database hosting - Stuck deployments and database connection issues (multiple regions)

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 12:25 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2025 - 11:48 UTC

Identified

We have identified the issue and are working on deploying a solution to all affected regions.
Posted Jun 10, 2025 - 09:48 UTC

Investigating

We are experiencing stuck deployments and database connection issues in the following locations:

Changhua County, Taiwan (asia-east1)
Hong Kong (asia-east2)
Tokyo, Japan (asia-northeast1)
Osaka, Japan (asia-northeast2)
Seoul, South Korea (asia-northeast3)
Mumbai, India (asia-south1)
Delhi, India (asia-south2)
Jurong West, Singapore (asia-southeast1)
Sydney, Australia (australia-southeast1)

This affects the Application & Database hosting only, Managed WordPress hosting instances are not affected at this moment.
Posted Jun 10, 2025 - 06:28 UTC