MyKinsta performance degradation

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 22:29 UTC

Monitoring

We've implemented a fix and we're monitoring the results.
Posted Mar 31, 2026 - 16:43 UTC

Investigating

We're currently seeing reports of performance issues inside MyKinsta, with some pages not loading or not loading fully, and we're investigating these issues.
Posted Mar 31, 2026 - 16:15 UTC
This incident affected: MyKinsta.