Service disruption at the Iowa (US Central) data center

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 22:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2025 - 14:17 UTC

Update

Our Engineers are continuing to investigate the issue.
Posted Sep 26, 2025 - 12:37 UTC

Update

Our Engineers are continuing to investigate the issue.
Posted Sep 26, 2025 - 12:32 UTC

Update

Our Engineers are continuing to investigate the issue. Thank you for your ongoing patience.
Posted Sep 26, 2025 - 11:36 UTC

Investigating

Our Engineers are investigating reports of a service disruption affecting some sites in the Iowa (US Central) data center. We are working to restore service to affected sites as quickly as possible.
Posted Sep 26, 2025 - 11:00 UTC
This incident affected: Iowa (US) data center.