Email deliverability issue with Kinsta's transactional email service (MailChannels)
Incident Report for Kinsta
Resolved
This incident has been resolved.
Posted Jan 30, 2025 - 00:55 UTC
Update
The service is stable. All messages that were queued in MailChannels systems have been delivered.
Posted Jan 29, 2025 - 23:50 UTC
Monitoring
The email deliverability latency is resolving. We are continuing to monitor this incident. Thank you for your patience.
Posted Jan 29, 2025 - 23:38 UTC
Investigating
MailChannels is currently experiencing higher than usual connection latency, which may affect email delivery services, as noted on their status page - https://status.mailchannels.net/incidents/xyj11g989swn. We are closely monitoring this incident.
Posted Jan 29, 2025 - 22:26 UTC
This incident affected: Outbound Email System.