Service disruption at the Singapore (SG) data center

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 22:17 UTC

Identified

We believe that we have identified the issue and are currently working on resolving this.
Posted Mar 17, 2025 - 20:12 UTC

Investigating

Our Engineers are investigating reports of a service disruption affecting sites in the Singapore (SG) data center. We are working to restore service to affected sites as quickly as possible.
Posted Mar 17, 2025 - 20:03 UTC
This incident affected: Singapore data centers.