MyKinsta Service Disruption
Incident Report for Kinsta
Resolved
All indications of the aforementioned performance issues appear to be resolved at this time. If you experience further slowness issues while using MyKinsta, please let us know.
Posted Mar 03, 2020 - 19:54 UTC
Investigating
Our Engineers are investigating the performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted Mar 03, 2020 - 19:43 UTC
This incident affected: MyKinsta.