MyKinsta Support System Unavailable

Incident Report for Kinsta

Resolved

Our support system is now available. We do apologize for any difficulties you experienced attempting to reach our support team.
Posted Jun 22, 2025 - 16:32 UTC

Investigating

Our support system is not currently available. We are working to resolve the issue as quickly as possible.
Posted Jun 22, 2025 - 16:25 UTC
This incident affected: Kinsta support system.