Environment creations are failing

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 22:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 15:45 UTC

Identified

We have identified the issue and we're currently implementing a fix.
Posted Oct 21, 2025 - 15:41 UTC

Investigating

We are currently seeing failures when trying to create site environments in MyKinsta. This is affecting new site creations, new Staging environment creations, and backup restores thus far. We are currently investigating the cause.
Posted Oct 21, 2025 - 15:31 UTC
This incident affected: MyKinsta.