MyKinsta dashboard login issues

Incident Report for Kinsta

Resolved

MyKinsta has remained operational during our monitoring, and as such, we will mark this incident as resolved. Thank you for your patience throughout this, and we do apologize for any issues you experienced attempting to access MyKinsta.
Posted Jun 22, 2026 - 17:31 UTC

Update

MyKinsta has remained fully operational since the solution was deployed. We will continue to monitor the situation.
Posted Jun 22, 2026 - 16:17 UTC

Monitoring

Our Engineering team has implemented a solution and is currently monitoring the results.
Posted Jun 22, 2026 - 15:27 UTC

Update

Our Engineering team are continuing to investigate the issue as a priority.
Posted Jun 22, 2026 - 15:14 UTC

Update

MyKinsta will be completely unavailable while our Engineering team continue to focus on resolving this issue. Websites are not impacted by this MyKinsta outage. Thank you for your continued patience.
Posted Jun 22, 2026 - 14:42 UTC

Update

Our Engineering team are continuing to investigate the issue.
Posted Jun 22, 2026 - 14:28 UTC

Update

Our Engineering team are continuing to investigate the issue. If you require assistance and are unable to log into MyKinsta, please reach out to our Support team by emailing support@kinsta.com.
Posted Jun 22, 2026 - 13:58 UTC

Update

Our Engineering team has identified that this is impacting other MyKinsta-related actions, such as creating new environments and adding domains to environments. We are continuing to investigate this issue. Thank you for your continued patience.
Posted Jun 22, 2026 - 13:28 UTC

Investigating

The fix we attempted to deploy didn't work, we are continuing to investigate this further on our end. We will provide updates as soon as they become available! Thanks for your understanding and patience.
Posted Jun 22, 2026 - 12:59 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 22, 2026 - 12:00 UTC

Investigating

We are currently investigating reports for new sessions in MyKinsta dashboard where the login to our dashboard is hanging.

We will provide updates as soon as they become available.
Posted Jun 22, 2026 - 11:18 UTC
This incident affected: MyKinsta.