MyKinsta service disruption
Incident Report for Kinsta
Resolved
This issue has been resolved.
Posted Jul 17, 2024 - 16:29 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2024 - 16:02 UTC
Investigating
Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted Jul 17, 2024 - 15:48 UTC
This incident affected: MyKinsta.