MyKinsta APM service disruption

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 08:53 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 09, 2026 - 08:00 UTC

Identified

We've identified the issue with our APM tool in MyKinsta. We are working on a fix for this.
Posted Jan 09, 2026 - 06:48 UTC

Update

We're still working on resolving this issue, and we sincerely apologize for any inconvenience it may have caused.
Posted Jan 09, 2026 - 05:55 UTC

Update

We are continuing to investigate this issue and apologize for any inconvenience it may cause.
Posted Jan 09, 2026 - 04:09 UTC

Update

We are continuing to investigate this issue and apologize for any inconvenience it may cause.
Posted Jan 09, 2026 - 02:52 UTC

Investigating

Our Engineers are investigating reports of performance issues with the APM data reported in MyKinsta. At this time APM data may not be displayed in MyKinsta. We are working to restore normal functionality to our APM system as quickly as possible. If you do have any questions please do not hesitate to reach out to our Support team for assistance. We apologize for this disruption.
Posted Jan 09, 2026 - 00:19 UTC
This incident affected: MyKinsta.