MyKinsta service disruption
Incident Report for Kinsta
Resolved
Our Engineers have successfully restored full service to our control panel, MyKinsta. Analytics should resume normal operations at this time. If you're seeing outdated/unusual data, please reach out to our support team by opening a chat with us.
Posted 26 days ago. Jul 25, 2019 - 20:01 UTC
Investigating
Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible. Affected services include but are not limited to Analytics.
Posted 27 days ago. Jul 24, 2019 - 23:06 UTC
This incident affected: MyKinsta.