KinstaCDN degraded performance affecting visitors from US and Singapore
Incident Report for Kinsta
Resolved
The problem has been resolved. All services are fully operational.
Posted Oct 02, 2020 - 14:25 UTC
Update
The incident in the US region has been successfully resolved. All services have been restored fully.
The degraded performance in the Singapore region is still being investigated with our CDN provider. We will update this page once further information is available.
Posted Oct 02, 2020 - 11:11 UTC
Update
We are continuing to investigate this issue with our CDN provider
Posted Oct 02, 2020 - 08:56 UTC
Investigating
Our Engineers are investigating reports of degraded performance with the KinstaCDN service that is affecting visitors from US and Singapore. If you are experiencing issues we recommend temporary disabling KinstaCDN.

You can disable the CDN in your MyKinsta dashboard under "CDN". If you need assistance with this, please contact our Support Team.
Posted Oct 02, 2020 - 08:21 UTC
This incident affected: Kinsta CDN.