This incident has been resolved. If you continue to experience similar issues, please contact our Support team via chat or email at support@kinsta.com.
Posted Jan 06, 2026 - 02:31 UTC
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Jan 06, 2026 - 01:50 UTC
Update
We are continuing to work on a fix to resolve this issue.
Posted Jan 06, 2026 - 01:49 UTC
Identified
The issue has been identified, and a fix is being implemented.
Posted Jan 06, 2026 - 00:35 UTC
Update
The MyKinsta dashboard is currently experiencing timeouts, which is causing some pages fail to load and certain actions failing to complete. We are actively investigating this issue and apologize for any inconvenience this may have caused.
Posted Jan 05, 2026 - 23:43 UTC
Investigating
MyKinsta actions, such as adding domains, updating redirects, etc. are failing to complete. We are currently investigating the issue.