MyKinsta Support System Unavailable

Incident Report for Kinsta

Resolved

Our support system is now available. We do apologize for any difficulties you experienced attempting to reach our support team.
Posted May 29, 2025 - 15:11 UTC

Monitoring

A fix has been implemented by Intercom and we are monitoring the results.
Posted May 29, 2025 - 14:33 UTC

Update

Intercom is currently working on this issue: https://www.intercomstatus.com/us-hosting
Posted May 29, 2025 - 14:27 UTC

Update

This appears to be due to an issue at our support system provider, Intercom. We are currently experiencing intermittent connectivity issues with their systems.
Posted May 29, 2025 - 14:25 UTC

Investigating

Our support system is not currently available. We are working to resolve the issue as quickly as possible.
Posted May 29, 2025 - 14:23 UTC
This incident affected: Kinsta support system.