The submission form for expedited site migration is failing to submit.

Incident Report for Kinsta

Resolved

Our Engineers have now resolved the issue. We apologise for any disruptions experienced while trying to submit a site migration and thank you for your patience through this.
Posted Apr 23, 2025 - 13:28 UTC

Investigating

We are investigating this issue. While we work on resolving the issue, please contact our Support team for a workaround. We apologize for the inconvenience.
Posted Apr 23, 2025 - 06:09 UTC
This incident affected: MyKinsta.