Degraded platform performance due to database connectivity issues

Incident Report for Kinsta

Resolved

We can confirm that this incident is fully resolved. If you're still experiencing any issues, please reach out to our Support team.
Posted Sep 02, 2025 - 15:23 UTC

Monitoring

We've successfully migrated our database and have begun restoring our services. We will continue to monitor the solution. This change will allow for service updates and deployments to resume on the platform.
Posted Sep 02, 2025 - 12:40 UTC

Identified

One of our Cloud SQL database instances fails to perform properly, so we are migrating to a new one. The Mykinsta dashboard's features may be unresponsive until this process is complete and we provide a new update.
Posted Sep 02, 2025 - 10:40 UTC

Investigating

We're currently investigating an issue with one of our internal databases. You may experience failed queries on our dashboard pages.
Posted Sep 02, 2025 - 10:39 UTC
This incident affected: MyKinsta.