MyKinsta displaying "Maintenance in progress"

Incident Report for Kinsta

Resolved

A fix has been implemented and the "Maintenance in progress" message should no longer be displaying in error. We again apologize about any concern this caused. If you do have any questions please do not hesitate to reach out to our Support team.
Posted Oct 10, 2025 - 21:37 UTC

Investigating

Our engineers are aware of an issue where MyKinsta is displaying a "Maintenance in progress" message. This message is being displayed in error, and services are not currently disrupted. We are working on implementing a fix as quickly as possible. We apologize for any concern this has caused. If you do have any questions please do not hesitate to reach out to our Support team.
Posted Oct 10, 2025 - 19:56 UTC
This incident affected: MyKinsta.