MyKinsta service disruption

Incident Report for Kinsta

Resolved

Our Engineers have successfully resolved the issues with our control panel, MyKinsta. If you are still experiencing issues or if you cannot access MyKinsta, please reach out to our support team via support@kinsta.com.
Posted Jun 07, 2023 - 20:48 UTC

Update

We are continuing to monitor for any further issues to our control panel, MyKinsta.
Posted Jun 07, 2023 - 20:42 UTC

Monitoring

Our Engineers have successfully restored full service to our control panel, MyKinsta, and are monitoring the results.
Posted Jun 07, 2023 - 19:57 UTC

Update

Our Engineers are continuing to work on restoring normal service to MyKinsta as quickly as possible. If you require support and cannot access MyKinsta, please reach out to our support team via support@kinsta.com.
Posted Jun 07, 2023 - 19:33 UTC

Update

Our Engineers have identified and are still working on the issue that is affecting MyKinsta. We will continue to keep you updated here on our status page. Thank you for your patience.
Posted Jun 07, 2023 - 19:01 UTC

Update

Our Engineers are continuing to work on restoring normal service to MyKinsta as quickly as possible.
Posted Jun 07, 2023 - 18:28 UTC

Identified

Our Engineers have identified a performance issue with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted Jun 07, 2023 - 17:52 UTC

Investigating

Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted Jun 07, 2023 - 17:05 UTC
This incident affected: MyKinsta.