MyKinsta service disruption
Incident Report for Kinsta
Resolved
Our Engineers have successfully restored full service to our control panel, MyKinsta. If you are still seeing issues in MyKinsta please contact our support team by sending an email to support@kinsta.com. We do apologize for this disruption to your business.
Posted May 23, 2023 - 19:44 UTC
Update
We are continuing to investigate this issue. Thank you for your patience.
Posted May 23, 2023 - 17:36 UTC
Update
We are still investigating intermittently failing actions within our control panel, MyKinsta. We apologize for the inconvenience and appreciate your patience.
Posted May 23, 2023 - 16:59 UTC
Update
We are continuing to investigate this issue.
Posted May 23, 2023 - 16:12 UTC
Investigating
Our Engineers are investigating reports of intermittently failing actions within our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted May 23, 2023 - 15:43 UTC
This incident affected: MyKinsta.