Unresponsiveness .club domains due to issue within the gTLD
Incident Report for Kinsta
Resolved
The .club domain names are resolving as expected now.

We are not seeing any official status from the gTLD so we are not able to advice the core of the outage at the moment.
Posted Oct 07, 2021 - 13:40 UTC
Identified
It has been identified a list of .club domain names are not resolving due to domains are not able to return the Nameservers used. It seems it is worldwide outage for this gTLD.
We will be monitoring the news and post another update once resolved.
Posted Oct 07, 2021 - 11:40 UTC