MyKinsta service disruption
Incident Report for Kinsta
Resolved
This incident has been resolved.
Posted Mar 09, 2023 - 09:50 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2023 - 09:18 UTC
Investigating
Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted Mar 09, 2023 - 09:00 UTC
This incident affected: MyKinsta.