Site creation failing in Mykinsta

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 10:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2026 - 10:30 UTC

Investigating

We are currently investigating the issue of site creation failing.
Posted Jun 01, 2026 - 09:52 UTC
This incident affected: MyKinsta.